Author Topic: Jamie’s WR500  (Read 1695 times)

0 Members and 1 Guest are viewing this topic.

Offline Jamie70

  • Yama-Pupil
  • *
  • Posts: 31
Re: Jamie’s WR500
« Reply #10 on: October 27, 2017, 07:54:57 PM »
Exhaust protection and mount:

Offline Jamie70

  • Yama-Pupil
  • *
  • Posts: 31
Re: Jamie’s WR500
« Reply #11 on: October 27, 2017, 07:56:09 PM »
Front and rear chain protection:

Offline Jamie70

  • Yama-Pupil
  • *
  • Posts: 31
Re: Jamie’s WR500
« Reply #12 on: October 27, 2017, 07:56:57 PM »
Rear disc protection:

Offline Jamie70

  • Yama-Pupil
  • *
  • Posts: 31
Re: Jamie’s WR500
« Reply #13 on: November 12, 2017, 04:14:07 PM »
Just a little update. Now have all of the missing clutch parts, but still waiting on a couple of things for the shifter mechanism. The original clutch perch was quite worn, so replaced it with a new one while fitting a new Venhill clutch cable (original seized).

Hopefully get to have a ride soon!

Cheers
Jamie

Online sweede490

  • Yama-God
  • ******
  • Posts: 5548
Re: Jamie’s WR500
« Reply #14 on: November 12, 2017, 08:30:23 PM »

 Sounds good Jamie, what was the issue with the shifter mechanism?

  The shaft on a 500 I had was bent and I used one from an IT250k as they are the same thru the IT
   Yz range




  Muzz

Offline Jamie70

  • Yama-Pupil
  • *
  • Posts: 31
Re: Jamie’s WR500
« Reply #15 on: November 12, 2017, 09:05:24 PM »
Main issue was that it was missing completely, like a few other things. There was no shifter either, so I’m wondering if it had been bent along with the shift shaft. The bike came with a new shift shaft, but didn’t realise until recently that the spring and spacer were also missing from the bits I have.

It’s been a bit of a pain tracking down parts, but I’ve had to find:
  • clutch basket
  • clutch hub
  • ball bearing for clutch actuation shaft
  • washer/spacer for clutch hub
  • clutch cover bolts
  • shift shaft spacer
  • shift shaft tension spring

Apart from what I’ve mentioned, there’s some new seals which I’ll fit, and I’d like to get a decompression valve fitted. Hopefully I can get it going after this. I will probably do more to it, like new bearings everywhere, new chain/sprockets, but for now I just want to see how it runs.

Cheers
Jamie

Offline Jamie70

  • Yama-Pupil
  • *
  • Posts: 31
Re: Jamie’s WR500
« Reply #16 on: February 12, 2018, 08:29:45 PM »
Brief update.

Couldn’t get the clutch to operate properly no matter what I did. Realised that my clutch hub was wrong (3R4 instead of 23X). Shouldn’t have trusted the ebay listing saying it was compatible >:(. Now have an operational clutch and a 3R4 clutch hub for sale 8).

Next weekend I’ll see if I can start it.

Cheers
Jamie